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LabVIEW Installation

You need the following Software

• LabVIEW (LabVIEW Professional Development System 32-Bit: English)

• NI-DAQmx (Hardware Driver for NI USB-6008, NI TC-01, 

etc.)

• LabVIEW Control Design and Simulation Module

• LabVIEW MathScript RT Module

Note! These packages are separate downloads! 

All LabVIEW Software can be downloaded here: www.ni.com/download

http://www.ni.com/download


Contents
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• Installation
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National Instruments is 
the vendor of LabVIEW

National Instruments creates 
both Hardware and Software



Hardware Examples

cRIO

ZigBee

Vision System

Arduino

USB-6008

Wi-Fi DAQ

TC-01

NOx Sensor

Pt-100

Air Heater

Water Tank



DAQmx is the Hardware Driver needed in order to use hardware devices like NI 
USB-6008, NI TC-01, etc. inside LabVIEW. The module is available as a palette on 
your block diagram.

LabVIEW
This is the core LabVIEW installation that installs 
the LabVIEW Programming Environment.

This module is a text-based tool that is very similar to MATLAB. The syntax 
is similar to MATLAB, you can create and run so-called m files, etc. The 
module is available from the Tools menu inside LabVIEW.

LabVIEW MathScript RT Module

LabVIEW Control Design and Simulation Module
This module is used for creating Control and Simulation applications with 
LabVIEW. Here you will find PID controllers, etc. The module is available 
as a palette on your block diagram.

NI-DAQmx 



http://www.ni.com/pdf/manuals/376039a.pdf

Students: Try some of these Shortcuts and Tools

http://www.ni.com/pdf/manuals/376039a.pdf


Control and Simulation in LabVIEW
Control Design & Simulation Palette in LabVIEW

Simulation Palette in LabVIEW

PID Palette in LabVIEW

Control Design Palette in LabVIEW

Students: Check that you have all these 
palettes. Open the different subpalettes, etc.

Simulation Loop



LabVIEW Control and Simulation Example

We are going to learn to create such a system (and much more)!

Example of Simulation (and control) of a 
dynamic system based on the blocks in 
the Simulation Palette
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Dynamic Systems Examples
Water Tank:

Mathematical Models (differential equations):

Air Heater:

Alt 1 (Integrator):

Alt 2 (Time constant/1.order):

Alt 3 (Nonlinear):h – Level in the tank

T – Temperature in the tube



Dynamic Systems Examples2 Tank:
Mathematical Models (differential equations):

4 Tank:



Integrator symbol

Dynamic system represented as a differential equation

Dynamic Systems

Dynamic system represented as a block diagram

When we have the block diagram for the system, we can easily implement it in LabVIEW

Note We can “easily” create a block diagram from the differential 
equation(s)

"̇ = −%" + '(



Block Diagram Examples

Students: Find the block diagrams for the differential equations above (pen & paper)

Example 1:

Example 2:



Block Diagrams - Solutions

or:

Example 1:

Example 2:



Block Diagram Examples

Students: Find the block diagram for the differential equation above (pen & paper)

Higher order differential equations
Mass-Spring-Damper Example:



Block Diagram - Solutions
Higher order differential equationsMass-Spring-Damper Example:



Simulation Tools
• MATLAB

– Text-based Programming Tool
– www.mathworks.com

• Simulink
– Block diagram-based Simulation, Integrated with MATLAB

• LabVIEW
• MathScript

– Uses MATLAB syntax, Integrated with LabVIEW
• Modelica

– https://www.modelica.org
• HYSYS

– http://www.aspentech.com/products/aspen-hysys.aspx
• ...

http://www.mathworks.com
https://www.modelica.org
http://www.aspentech.com/products/aspen-hysys.aspx
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Simulation in LabVIEW
Simulation Palette in LabVIEW Simulation Loop: Similar to a While Loop, but cusomized for used 

together with the Simulation Blocks available in LabVIEW 

Different Simulation Blocks by Category
• Continuous Systems
• Discrete Systems
• Nonlinear Systems
• etc.



Simulation Example

Students: Implement and Simulate this system in LabVIEW

Integrator symbol

Dynamic system represented as a differential equation

"̇ = −%" + '(



Simulation Example - Configuration
In the example the following simulation parameters could be used (right-click on the Simulation 
Loop border and select “Configure Simulation parameters…”): 



Simulation Example - Solutions

Step Response
We see the Step Response
is as expected!

Correct results? – Check static response:

Try with different values for u

"̇ = −%" + '(



PID Control in LabVIEW
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Control Systems

PID Process

Sensor

r e u y

-

Kp Ti Td

v

Example of Industrial Controllers

Students: What is r, e, u, v, y, Kp, Ti, Td?

Typical Block Diagram:

DeltaV
PID Controller



Control System

PID Process

Sensor

r e u y
-

Kp Ti Td

v

r – Reference Value, SP (Setpoint), SV (Set Value)
y – Measurement Value (MV), Process Value (PV)
e – Error between the reference value and the measurement value (e = r – y)
v – Disturbance, makes it more complicated to control the process
Kp, Ti, Td – PID parameters

PID Algorithm:



Control System implementation in LabVIEW

PID Process

Sensor

r e u y
-

Kp Ti Td

vControl System implementation with “Pen & Paper”

The transition from “paper” to LabVIEW is 
easy, because the implementation is very 
similar to the “paper” version

Here we have used the “Simulation Loop”

Example



PID Process

Sensor

r e u y
-

Controller
Kp Ti Td

v

Control System implementation in LabVIEW

Control System implementation with “Pen & Paper”

All this is normally 
included in the controller

The transition from “paper” to LabVIEW is 
easy, because the implementation is very 
similar to the “paper” version

Here we have used an ordinary While Loop 
(which is recommended!)

Example



PID Control in LabVIEW
PID Palette in LabVIEW (PID Toolkit)

Note! The functions “PID.vi” and “PID Advanced.vi” requires that Ti and Td are in minutes, 
while it’s normal to use seconds as the unit for these parameters. You can use the following 
piece of code in order to transform them:
This means we enter values for Ti and Td in seconds on the Front Panel and the values are 
converted to minutes in the code.

Alternative 1: Alternative 2:

This alternative 
uses seconds!



LabVIEW PID Example

Students: Replace u in the previous example with the built-in PID Controller (use Alternative 2)

"̇ = −%" + '(



PID Example - Solutions

Front Panel:

Students: Find proper !", #$, #% Parameters for this system. Use “Trial and Error” (or a more systematic approach)

'̇ = −*' + ,-



PID Example - Solutions

Block Diagram:

Right-click (Configuration) on the PID block 
to select Kp, Ti, Td as Inputs (->Terminals)

"̇ = −%" + '(



Next Step: Continuous Simulation

Students: Change your Simulation Settings and Run your 
Simulation with these changes

Add a Stop Button
and a “Halt Simulation” block

Right-click on the Simulation Loop 
border and select “Configure 
Simulation Parameters…”

Simulation in “Real Time”
Inf = Infinite



PID Example – Continuous Simulation - Solution

The Simulation now runs until you press 
the Stop button

Students: 
Extend the example with a new Chart of the Control Signal 
(u) and include the reference signal (r) in the existing Chart, 
so you can easily see the changes in r and how the system 
handle it.



Simulation Subsystems
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Create a Subsystem of this part (your process model)

Simulation Subsystem
A Way to structure your code, similar to SubVIs

Students: Change your code above where you create a Simulation Sub System for your Process

File -> New…

This is the recommended way to do it! – You can easly reuse your Subsystems in 
different VIs and your code becomes more structured!

Select File -> New ..., Then choose “Simulation 
Subsystem”. Copy (or move) the blocks containing your 
process into the New VI (Simulation Subsystem) 



Simulation Subsystem - Solutions

File -> New…



Simulation Subsystem 2 (PID Controller)

Create a Subsystem of this part (the PID controller)

Students: Change your code above where you create a Simulation Sub System for the PID Controller as well.



Simulation Subsystem – Solutions2

Now your code has become 
really simple to understand!

Note! You may select 
different icon style

Simulation Sub Systems



Simulations using a While Loop
Note! The Simulation Loop has some drawbacks/is more complicated to use than an ordinary While 
Loop. If we use Simulation Subsystems, we can use them inside a While Loop instead!  - which 
becomes very handy!

So for real applications that involves more than just 
simulations (such as DAQ, File Logging, PID control of 
the real process, etc.), I recommend to use a While 
Loop instead of a Simulation Loop.

Simulation Subsystems

Students: Add your Controller and Process Subsystems inside a While loop as shown above. Simulate the system. 
Do you get the same results?
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Save Data to File (Datalogging)

Right-click-Properties

Recommended Settings



Datalogging Example



Students: (1) Log Data from your system, i.e., the Control Signal (u) and the output of 
the process (y) to a “Measurement File”. (2) Then Plot the Data from the File in Excel.

Datalogging Example – Block Diagram



Discrete Systems
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Continuous Signal

Discret Signal A computer can only deal 
with discrete signals

k = 0, 1, 2, 3, 4, ....

Ts = Sampling Time

Note! 
Different 
books use 
different 
notations When Ts -> 0, we have a continuous signal, 

but in a computer that is not possible.



Discretization
Example

In order to simulate this system in LabVIEW using the Formula 
Node we need to find the discrete differential equation.

Given the following differential equation:

We can use e.g., the Euler Approximation:
Ts – Sampling Time

Then we get:

This gives the following discrete differential equation:

"̇ = −%" + '(



Formula Node/MathScript
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Formula Node & MathScript Node

MathScript Node: Create and use 
MathScript/MATLAB code within LabVIEW

Formula Node: Create and use C code 
within LabVIEW

Example:

Very useful for mathematical expressions and 
simulations!

Right-click on the border to 
Add Input or Add Output



Formula Node/MathScript Node

Students: Create this Example both in Formula Node 
and in MathScript Node

Students: Try this Formula as well (both in 
Formula Node and in MathScript Node):



Simulate Discrete Systems using the Formula Node in 
LabVIEW

Example

In order to simulate this system in LabVIEW using the Formula 
Node we need to find the discrete differential equation.

Given the following differential equation:

We can use the Euler Approximation: Ts – Sampling Time

Then we get:

This gives the following discrete differential equation:

Students: Simulate and Plot the discrete system above using a Formula Node 
and a For Loop in LabVIEW Ts = 0.1 s 

"̇ = −%" + '(



Formula Node in LabVIEW - Solutions

As expected, we get the same results as in 
the previous example using a block diagram 
simulation

Students: Improve your solution by 
creating a SubVI of your model

xk1=(1-a*Ts)*xk + Ts*b*uk;
Discrete model:



Formula Node in LabVIEW – Solutions 2

SubVI

Main VI

Advantages using SubVI:
• Our Main program has become simpler and easier to 

understand and maintain
• We can reuse our model in other applications
• If we need to do changes in the model, we only do it once and in 

one place!



MathScript
LabVIEW MathScript RT Module

Add-on Module for LabVIEW where 
we can do text-based programming 
and simulations 
– very powerful!



MathScript
Simulation Example

% Simulation of discrete model
clear, clc

% Model Parameters
a = 0.25;b = 2;

% Simulation Parameters
Ts = 0.1; %s
Tstop = 20; %s
uk = 1; % Step Response
x(1) = 0;

% Simulation
for k=1:(Tstop/Ts)

x(k+1) = (1-a*Ts).*x(k) + Ts*b*uk;
end

% Plot the Simulation Results
k=0:Ts:Tstop;
plot(k,x)
grid on

Students: Create and test the MathScript code. You 
should get the same results as in the LabVIEW Examples

Create the following code in the 
MathScript “Script Editor” 

"̇ = −%" + '(



MathScript Node
Students: Try the same example inside LabVIEW using the MathScript Node

Just copy and paste the code from 
the previous example



Do you need more Practice? - Select a Challenge
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Students: Simulate this system using LabVIEW. Plot the position, speed and the accelleration. Test with 
different values on m, k and d. 

Mass-Spring-Damper System

http://www.techteach.no/simview/mass_spring_damper/index.php

http://www.techteach.no/simview/mass_spring_damper/index.php


A sketch of the Air Heater System:

Air Heater Overview

Temperature
Measurement

Air In

Control 
Signal

Heater

Air Out

TT

Air tube
Air flow

TC

Real Air Heater



In this assignment we are going to simulate and control a mathematical model of an Air Heater system. 

A mathematical model of the system could be: 

Use the following values in the simulations:

Where:

Air Heater Simulation

Note! You find an example of how to do it in LabVIEW on the next slides – but try to solve 
it by yourself first!



Implement the Heater model in a Simulation Sub System, as shown below:

See next slide for Front 
Panel example

Air Heater Simulation Example



Front Panel Example:

Air Heater Simulation

Find Proper PI(D) Parameters



Air Heater Simulation
with MathScript % Simulation of discrete model

clear, clc

% Model Parameters
a = 0.25;b = 2;

% Simulation Parameters
Ts = 0.1; %s
Tstop = 20; %s
uk = 1;
x(1) = 0;

% Simulation
for k=1:(Tstop/Ts)

x(k+1) = (1-a*Ts).*x(k) + Ts*b*uk;
end

% Plot the Simulation Results
k=0:Ts:Tstop;
plot (k, x)
grid on

Are you able to simulate the Air 
Heater model using MathScript 
or/and MathScript Node?

MathScript Simulation Example
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